Главная >> Информатика 8 класс. Босова

 

 

 

 

§ 2.4. Основные алгоритмические конструкции

Повторение. Основные алгоритмические конструкции

Повторение — алгоритмическая конструкция, представляющая собой последовательность действий, выполняемых многократно. Алгоритмы, содержащие конструкцию повторения, называют циклическими или циклами. Последовательность действий, многократно повторяющаяся в процессе выполнения цикла, называется телом цикла.

В зависимости от способа организации повторений различают три типа циклов:

    1) цикл с заданным условием продолжения работы;
    2) цикл с заданным условием окончания работы;
    3) цикл с заданным числом повторений.

Цикл с заданным условием продолжения работы (цикл-ПОКА, цикл с предусловием)

Логика работы этой конструкции описывается схемой, показанной на рис. 2.10.

    Цикл с предусловием

На алгоритмическом языке эта конструкция записывается так:

    нц пока <условие>
        <тело цикла (последовательность действий)>
    кц

Выполняется цикл-ПОКА следующим образом: 1) проверяется условие (вычисляется значение логического выражения); 2) если условие удовлетворяется (Да), то выполняется тело цикла и снова осуществляется переход к проверке условия; если же условие не удовлетворяется, то выполнение цикла заканчивается. Возможны случаи, когда тело цикла не будет выполнено ни разу.

Пример 12. Алгоритм, по которому из всех имеющихся кирпичей отбираются целые кирпичи и складываются в машину.

    алг отбор
    нач
      нц пока есть кирпичи
        взять один кирпич
        если кирпич целый
          то положить кирпич в машину
        иначе отложить кирпич в сторону
        все
      кц кон

Пример 13. Правее Робота (клетка со звёздочкой) расположен коридор неизвестной длины. Необходимо, чтобы Робот закрасил все клетки этого коридора.

Пока будет выполняться условие справа свободно, Роботу следует выполнять команды:

    вправо
    закрась

Соответствующий алгоритм для Робота будет иметь вид:

    нц пока справа свободно
      вправо
      закрась
    кц

Пример 14. Требуется, не пользуясь операцией деления, получить частное q и остаток r от деления натурального числа х на натуральное число у.

Представим операцию деления как последовательные вычитания делителя из делимого. Причём вычитать будем до тех пор, пока результат вычитания не станет меньше вычитаемого (делителя). В этом случае количество вычитаний будет равно частному от деления q, а последняя разность — остатку от деления r.

Исполним этот алгоритм для х = 23 и у = 5.

Ознакомьтесь с размещённым в Единой коллекции цифровых образовательных ресурсов модулем для коллективной работы «Циклические алгоритмы с предусловием» (217033). Совместно с друзьями постарайтесь составить алгоритмы для имеющихся в модуле задач. Пройдите тестирование.

Продолжение >>>

 

 

Рейтинг@Mail.ru