Главная >> Информатика 8 класс. Босова

§ 3.3. Программирование линейных алгоритмов

3.3.2. Целочисленный тип данных

Над целыми числами в языке Паскаль выполняются следующие операции: сложение (+), вычитание (-), умножение (*), получение целого частного (div), получение целого остатка деления (mod) и деление (/). Результаты первых пяти операций — целые числа. Результатом операции деления может быть вещественное число. Рассмотрим пример использования операций div и mod, записав на языке Паскаль программу нахождения суммы цифр вводимого с клавиатуры натурального трёхзначного числа. Используем тот факт, что положительное трёхзначное число можно представить в виде следующей суммы: х = а•100 + b•10 + с, где а, b, с — цифры числа.

    program n_4;
      var х, a, b, с, s: integer;
    begin
      writeln ('Нахождение суммы цифр трёхзначного числа') ;
      write ('Введите исходное число»');
      readln (х);
      а:=х div 100;
      b:=x mod 100 div 10;
      с:=х mod 10;
      s:=a+b+c;
      writeln ( 's= ', s)

    end.

Чему равна сумма цифр числа 123? А числа -123? Совпадают ли ваши результаты с результатами работы программы? Как можно объяснить и исправить ошибку в программе?

 

 

???????@Mail.ru