Главная >> Информатика 8 класс. Босова

Глава 3. Начала программирования

Начала программирования. Тестовые задания для самоконтроля (продолжение)

11. Какая клавиша нажимается после набора последнего данного в операторе read?

    а) Enter
    б) точка с запятой
    в) пробел
    г) Ctrl

12. При присваивании изменяется:

    а) имя переменной
    б) тип переменной
    в) значение переменной
    г) значение константы

13. Для вывода результатов в Паскале используется оператор

    а) begin
    б) readln
    в) write
    г) print

14. Для вычисления квадратного корня из х используется функция:

    а) abs(х)
    б) sqr (х)
    в) sqrt(х)
    г) int (х)

15. Для генерации случайного целого числа из интервала [10, 20) необходимо использовать выражение:

    а) random*20
    б) random(20)
    в) random(10)+10
    г) random(10) *2

16. В каком из условных операторов допущена ошибка?

    а) if b=0 then writeln ('Деление невозможно.');
    б) if a<b then min:=a; else min:=b;
    в) if a>b then max:=a else max:=b;
    г) if (a>b) and (b>0) then c:=a+b;

17. В условном операторе и после then, и после else нельзя использовать:

    а) оператор вывода
    б) составной оператор
    в) несколько операторов
    г) условный оператор

18. Определите значение переменной с после выполнения следующего фрагмента программы.

    а:=100;
    b:=30;
    а:=а-b*3;
    if a>b then c:=a-b else c:=b-a;

    а) 20
    б) 70
    в) -20
    г) 180

19. Условный оператор

if a mod 2=0 then write ('Да') else write ('Нет') позволяет определить, является ли число а:

    а) целым
    б) двузначным
    в) чётным
    г) простым

20. Какого оператора цикла не существует в языке Паскаль?

    а) for
    б) while
    в) repeat...until
    г) loop

<<< К началу          Окончание >>>

 

 

???????@Mail.ru