Главная >> Информатика 8 класс. Босова

Программирование линейных алгоритмов

Программирование линейных алгоритмов. Вопросы и задания (продолжение)

5. Известны координаты вершин А, В, С треугольника. Напишите программу, вычисляющую площадь этого треугольника.

6. Если сумма налога исчисляется в рублях и копейках, то налоговая служба округляет её до ближайшего рубля (до 50 копеек — с недостатком, свыше 50 копеек (включая 50) — с избытком). Используйте компьютер, чтобы ввести точную сумму налога и вывести, сколько следует уплатить.

7. Исследуйте работу функции random, запустив многократно на выполнение программу:

    program n_8;
      var х, n: integer;
    begin
      writeln ('Исследование функции random');
      randomize (*для генерации различных случайных
            чисел при каждом запуске программы *);
      write ('Введите х»');
      readln (х) ;
      write ('Введите n»');
      readln (п) ;
      writeln ('random(', х, ')=', random(х) ) ;
      writeln ('random(', х, ')+', n, '=', random(x)+n)

    end.

Как можно получить случайное число из интервала (0, x)?
Как можно получить случайное число из интервала (0, x]?
Как можно получить случайное число из интервала (n, х + n)?

8. Одна компания выпустила лотерейные билеты трёх разрядов: для молодежи, для взрослых и для пенсионеров. Номера билетов каждого разряда лежат в пределах:

    для молодёжи — от 1 до 100;
    для взрослых — от 101 до 200;
    для пенсионеров — от 201 до 250.

С помощью компьютера выберите случайным образом лотерейный билет в каждом разряде.

9. Запишите на языке Паскаль программу, которая для произвольного натурального двузначного числа определяет:

    а) сумму и произведение его цифр;
    б) число, образованное перестановкой цифр исходного числа.

<<< К началу          Окончание >>>

 

 

???????@Mail.ru