Главная >> Информатика 8 класс. Босова

§ 3.4. Программирование разветвляющихся алгоритмов

Программирование разветвляющихся алгоритмов. Вопросы и задания

Самое главное

При записи на языке Паскаль разветвляющихся алгоритмов используют условный оператор:

    if <условие> then <оператор_1> else <оператор_2>

Для записи неполных ветвлений используется неполный условный оператор:

    if <условие> then <оператор>

Если при некотором условии требуется выполнить определённую последовательных операторов, то их объединяют в один составной оператор, имеющий вид:

    begin <последовательность операторов> end

Вопросы и задания

1. Ознакомьтесь с материалами презентации к параграфу, содержащейся в электронном приложении к учебнику. Используйте эти материалы при подготовке ответов на вопросы и выполнении заданий.

2. Как на языке Паскаль записывается полное и неполное ветвление?

3. Является ли условным оператором следующая последовательность символов?

    а) if х<у then х:=0 else read (у)
    б) if х>=у then х:=0; у:=0 else write (z)
    в) if x<y<z then a:=a+1

4. Что такое составной оператор? Для чего он используется в условном операторе?

5. Используя составной оператор, упростите следующий фрагмент программы:

    if a>b then с:=1;
    if a>b then d:=2;
    if a<=b then c:=3;
    if a<=b then d:=4

6. Дано трёхзначное число. Напишите программу, которая определяет:

    а) есть ли среди цифр заданного целого трёхзначного числа одинаковые;

    б) является ли число «перевёртышем», т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево.

7. Даны две точки в плоской прямоугольной системе координат. Напишите программу, определяющую, которая из точек находится ближе к началу координат.

Окончание >>>

 

 

???????@Mail.ru