Главная >> Информатика 8 класс. Босова

§ 3.5 Программирование циклических алгоритмов

3.5.3. Программирование циклов с заданным числом повторений

Цикл с заданным числом повторений (цикл-ДЛЯ) программируется в языке Паскаль с помощью оператора for. Его общий вид:

    for <параметр>:=<начальное_значение> to <конечное_значение> do <оператор>

Здесь:

    <параметр> — переменная целого типа;

    <начальное_значение> и <конечное_значение> — выражения того же типа, что и параметр, вычисляемые перед началом цикла;

    <оператор> — простой или составной оператор — тело цикла.

При выполнении этого оператора после каждого выполнения тела цикла происходит увеличение на единицу параметра цикла; условием выхода из цикла является превышение параметром конечного значения.

Запишем на языке Паскаль рассмотренный в п. 2.4.3 (пример 19) алгоритм вычисления степени с натуральным показателем n для любого вещественного числа а.

    program n_16;
        var i, n: integer; a, y: real;
    begin
        writeln ('Возведение в степень');
        write ('Введите основание а>>');
        readln (а);
        write ('Введите показатель n>>');
        readln (n);
        у:=1;
        for i:=1 to n do y:=y*a;
        writeln ('y=', y)
    end.

 

 

???????@Mail.ru